linux-latest and linux53 are in conflict — Feb 21, 2020

If you’re running Manjaro Linux on ThinkPad and you tried to update your system recently, you might have run into this problem. I encountered it with a ThinkPad T420s and a ThinkPad P50 both running Manjaro-i3.

After attemping an update from the terminal with something like:

➜  ~ sudo pacman -Syu --noconfirm

… and you encounter and error like this:

looking for conflicting packages...
:: linux-latest and linux53 are in conflict. Remove linux53? [y/N]
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: linux-latest and linux53 are in conflict

… you can overcome it by removing linux-latest like this:

➜  ~ sudo pacman -Rns linux-latest

Then try the update again:

➜  ~ sudo pacman -Syu --noconfirm

This worked for me. There are a couple threads going around with other context. This article gives you a simply, straight-forward way to overcome the error that worked on two ThinkPads that are right in front of me. I hope this helped someone out.

BR,
Tim Beach

If you’re here, you’re probably already a Manjaro Linux user, which is a convenient way to get an Arch Linux system up and maintainable. I also recommend going through the Arch install process yourself. I’ve done it a few times on different systems, and it is a good learning experience. Luke Smith has some cool content around this topic.

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store